US Degradation

Incident Report for VerifiNow

Resolved

Services are stable and back to normal levels.
Posted Jul 02, 2026 - 22:49 UTC

Monitoring

Response times have returned to normal. We're continuing to closely watch the services before confirming full resolution.
Posted Jul 02, 2026 - 22:38 UTC

Update

We're currently experiencing elevated latency and intermittent errors across US identity verification services (ID, face, liveness, KYC/KYB, watchlists); our team is actively investigating and working on a resolution. Updates to follow.
Posted Jul 02, 2026 - 22:34 UTC

Identified

All US services (including identity, face, liveness, KYC, KYB, watchlist, and onboarding endpoints) are experiencing elevated latency, errors, and timeouts. Our engineering team has identified the root cause as an issue with a backend database dependency and is actively applying a fix to restore normal performance. Some customers may continue to see intermittent errors while the mitigation takes effect.
Posted Jul 02, 2026 - 22:15 UTC

Monitoring

We identified elevated latency, errors, and timeouts affecting US services related to a backend database dependency issue.

Our engineering team has applied mitigations and response times are trending back toward normal. We are continuing to closely monitor the situation to confirm full recovery.
Posted Jul 02, 2026 - 22:05 UTC

Update

Our team continues to investigate.

Status: General Degradation
Impact: High latency, errors, and timeouts
Posted Jul 02, 2026 - 22:02 UTC

Investigating

We are currently investigating this issue.
Posted Jul 02, 2026 - 21:46 UTC
This incident affected: Verifications Services (United States Region).