Elevated error rates

Incident Report for VerifiNow

Resolved

Identity verification requests are operating normally. The issue has been resolved.
Posted Sep 01, 2026 - 09:02 PDT

Identified

A fix has been applied and identity verification requests in our Canada
environment are completing normally. We are now monitoring the environment to
confirm full stability.

We will post a final update once monitoring is complete.
Posted Sep 01, 2026 - 08:12 PDT

Update

Identity verification requests have recovered and now completing successfully. We are continuing to monitor the environment
closely and are working to restore full stability.

We will provide a further update within 60 minutes, or sooner if the situation changes.
Posted Sep 01, 2026 - 07:56 PDT

Investigating

We are currently investigating elevated error rates affecting identity verification
requests. Some users may experience failures when capturing a selfie or an ID document.

Our engineering team is actively investigating. We will provide an update within
30 minutes.
Posted Sep 01, 2026 - 07:42 PDT
This incident affected: Verifications Services (Canada Region).