Degradation in US environment

Incident Report for VerifiNow

Resolved

This incident has been resolved. The US environment is operating normally. We apologize for any disruption caused.
Posted Aug 31, 2026 - 16:19 PDT

Update

Service has been stable for the past 20 minutes. Our team continues to investigate and is monitoring closely to confirm full stability.
Posted Aug 31, 2026 - 16:05 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 31, 2026 - 15:55 PDT

Update

We are currently investigating intermittent periods of elevated latency affecting the US environment. Some requests may take longer than usual to complete or return an error, and the behavior may be intermittent rather than continuous.

Our engineering team is actively investigating and working to restore normal performance.
Posted Aug 31, 2026 - 15:48 PDT

Monitoring

On August 31, 2026, beginning at 15:58 CST, the VerifiNow US platform experienced a period of service degradation. Elevated response times in a backend component triggered automatic protection mechanisms, resulting in intermittent HTTP 503 errors affecting access to the US Dashboard and calls to the /omni/start and /omni/internal/dashboard/flow endpoints. Service partially recovered between 16:05 and 16:22 CST before degrading again, with full recovery confirmed at 16:31 CST. Sessions initiated during the impact window may not have completed and would require a retry. The environment remains under active monitoring while our engineering team completes its investigation; a formal root cause analysis will follow.
Posted Aug 31, 2026 - 15:37 PDT

Investigating

We have detected a degradation in one of our environments; We are currently investigating.
Posted Aug 31, 2026 - 15:35 PDT
This incident affected: Verifications Services (United States Region).