Session display lag in the all sessions view

Incident Report for VerifiNow

Resolved

This incident has been resolved.
Posted May 04, 2026 - 12:38 UTC

Identified

In the US environment, sessions may appear after a slight 10-15 lag in the all sessions view. We implemented a fix, and we will keep sharing updates.
Posted May 04, 2026 - 12:13 UTC
This incident affected: Verifications Services (United States Region).